Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
Open CASCADEShowroomGet it!Developer CornerSupport and ProductsAbout us
Technical overview
Areas of use
Advantages
FAQ
Screenshots
Shape factory
Shape gallery
Demonstrations
What's new
System requirements
Download Center
Public license
Documentation
Getting started
Forums
Open Source community
Training and e-learning
A-la Carte Support
Value-added software
Complementary Components
Customer Corner
Company Profile
Marketing Materials
Contact Us
News
Home / Developer Corner / Forums / Installation and building / Building for a new platform

Building for a new platform

Building for a new platform
Jean-Marc Henriette 2005/10/22 18:58
I am trying to port OCC to a new platform (Unix Based) .

I've started by downloading the Linux 5.2 release (sigh more then 1 year old) and running the java installer to install the source files since there doesn't seem to be any other way to get them.

the following files/directories are created at the install level

doc
setupLinux.bin
LICENSE
uninstall
samples
tools
wok
log.txt
ros
setup.jar

Keep in mind this is on a non-linux platform, so I can't run any executables that might be provided here.

I try to find $CASROOT/adm/make/ as stated in 89_WebHELP/welcome/building_modules.htm but the only adm directory I find is in ros and contains no makefile or autoconf files.

There doesn't seem to be a top level makefile that let's you at least figure out how the whole thing goes together or the libraries gets made or anything, I would be more then happy to provide an FAQ to explain this process if someone could point me in the correct direction.
I found http://sourceforge.net/projects/autoopencas which gives me some ideas but doesn't seem to have been updated since 2001. I suppose it gives me a starting point, but starting with 4 year old code is really going to slow this down.

Any ideas?
~JM



Etienne LORRIAUX 2005/10/24 12:57
Hello Jean-Marc

the ros directory should contain a configure script. I've already tried to compile OCC modules on Gentoo/Alpha or Tru64Unix/Alpha and it wotks quite fine. Be sure to use gcc-3.2.3 and tcl/tk-8.3.4 and precise it to the configure script.
Jean-Marc Henriette 2005/10/25 16:07
Thanks Etienne,

I've downloaded both the Linux and Solaris public installs(5.2) and run "setup.jar" . The ros directory that is created as part of each installation doesn't seem to contain any files at the root /ros/ level , just directories. Am I doing something wrong in the installation process? I've tried to re-install several time (making sure to triple check that the build procedure and source are included. It there another place I can get these configure files?

~JM
Etienne LORRIAUX 2005/10/26 11:06
How do you install OCC ?

You have to run 'java -jar setup.jar' (or the install script) and use the java install frontend. If you leave install directories to their default config, it should create /opt/OpenCASCADE5.2 that contains binaries and sources, depending on your choices during install. And you should find something like this :

tetienne@gentoo-laptop /opt/OpenCASCADE5.2/ros $ ls -al
total 4156
drwxr-xr-x 8 root root 4096 oct 8 03:05 .
drwxr-xr-x 9 root root 4096 déc 6 2004 ..
-rwxrwxrwx 1 root root 44301 jui 13 2004 acinclude.m4
-rwxrwxrwx 1 root root 200296 jui 13 2004 aclocal.m4
drwxrwxrwx 4 root root 4096 déc 6 2004 adm
-rw-r--r-- 1 root root 2295885 sep 25 14:26 adm.tar.gz
-rw-r--r-- 1 root root 400 sep 16 15:52 com.log
-rw-r--r-- 1 root root 10305 oct 6 17:38 config.h
-rwxrwxrwx 1 root root 9784 jui 13 2004 config.h.in
-rw-r--r-- 1 root root 196711 oct 8 03:05 config.log
-rwxr-xr-x 1 root root 54698 oct 8 03:04 config.status
-rwxrwxrwx 1 root root 492663 jui 13 2004 configure
-rwxrwxrwx 1 root root 19990 jui 13 2004 configure.in
drwxr-xr-x 526 root root 12288 déc 6 2004 drv
-rw-r--r-- 1 root root 1840 déc 6 2004 env.csh
-rw-r--r-- 1 root root 1835 déc 6 2004 env.ksh
drwxr-xr-x 2 root root 626688 oct 6 23:12 inc
-rwxr-xr-x 1 root root 151364 oct 8 03:03 libtool
drwxr-xr-x 4 root root 4096 oct 5 19:42 lin
lrwxrwxrwx 1 root root 27 déc 10 2004 Linux -> /opt/OpenCASCADE5.2/ros/lin
drwxrwxrwx 2 root root 4096 déc 6 2004 make
-rw-r--r-- 1 root root 18936 oct 8 03:04 Makefile
-rwxrwxrwx 1 root root 897 jui 13 2004 Makefile.am
-rwxrwxrwx 1 root root 18635 jui 13 2004 Makefile.in
drwxr-xr-x 526 root root 12288 déc 6 2004 src
-rw-r--r-- 1 root root 23 oct 8 03:05 stamp-h1

If you have problems with the java install, you can do the install process on a linux machine and then copy the /opt/OpenCASCADE5.2/ros directory to your Unix machine to compile it.
Jean-Marc Henriette 2005/11/18 17:27
Just to finish out the thread, I ended up finding someone with a Linux box to help me out. It's a pretty bad solution and IMHO should be fixed to allow a source only all-platform download option, or modify the installer to allow you to pick which OS you are running the installer as (defaulting to `uname`).
~JM
 
 
Latest news
  • Open CASCADE Technology 6.7.0 is available for download!
  • Open CASCADE Technology 6.6.0 is available for download!
  • Open CASCADE Technology 6.5.5 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map