Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
 

Unable to start Installer of OCC 5.2

Unable to start Installer of OCC 5.2
Erkka Westman 2004/07/20 08:51
When I try to start the installer it won't start. I tested it on other machine with Debian sarge-testing and everything went well.
System where installer isn't working is using Kernel 2.6, may this be the problem?
Should all dependencies/system requirements be met before trying to install or can I install the files without mesa and other?

Installer doesnt complain anything, it just prints dots as if it was starting up but then it returns to shell.
lsj 2004/07/20 09:49
The install program is a java runtime -- from strace:
execve("/tmp/isj5f0Lag/Linux-Sun-1.3.1_06.bin" ...
and execve("/tmp/isj5f0Lag/bin/java", ["/tmp/isj5f0Lag/bin/java", "-cp", ":setup.jar:", "-Dtemp.dir=/tmp", "-Dis.jvm.home=/tmp/isj5f0Lag", "-Dis.jvm.temp=1", "-Dis.media.home="

It it can be caused by the NPTL threads?
And it won't work on none i86 linux!
Workaround is to run java instead: java -jar ./Linux/setup.jar
and use configure/make to compile it.
I can't compile via OCC.COMP bacause the Draw.COMP is the same as Draw.comp, so it will not compile the submodule TKDraw.comp
Cliff Johnson 2004/07/22 06:29
Both the setup executable and running using your advice failed for me on both my debian sarge machines ( 1 using 2.4 and 1 using 2.6 kernels)

Webmaster: Can we PLEASE have an ordinary .tar.gz file of the source available on the download page?

Thanks,

Cliff
Stephane Routelous 2004/07/22 06:37
I installed it on Mandrake Linux 10.0
What I have seen is that you HAVE to have the Sun JRE. By default, with Mandrake comes Kaffe, and it doesn't work. So I had to uninstall Kaffe and take the Sun version.
And, you also need to have a graphical desktop environment (such as KDE) because the installer is now a wizard-like installer (InstallShield with Java)

HTH,

Stephane
Hunter 2004/11/24 15:51
Hi, Stephane:

I use MDK10.1 and I couldn't get DRAWEXE to work, It said

"./DRAWEXE: error while loading shared libraries: libTKDraw.so: cannot open shared object file: No such file or directory"

But I'm sure the file libTKDraw.so is in the directory of /OpenCascade/ros/lin/lib.

any suggestion would be appreciated~

sincerely
bruno boyer 2005/01/09 09:53
I have the same problem today... If you have had the solution, i'm very interested... Thank you very much.
stef 2005/01/23 17:49
Maybe the environment variables are not set.
See http://www.opencascade.org/org/gettingstarted/install/envvar/. In the 7th line of the 'Unix platform' section it says: setenv PATH $CASROOT/../3rdparty/$OS_NAME/tcltk/bin:$CASROOT/$OS_NAME/bin
I don't know much about this stuff either, but it says this is a c-shell ('csh') script. I tried to run this script on the c shell, with
bash> csh
#./env.csh
but it did'nt work.
So I set the variables in bash:
export PATH=$PATH':/opt/OpenCASCADE5.2/ros/bin' , and so on...
It still doesn't work, but for a different reason: now libtcl.so.0 can't be found. I guess I have to install the tcl library now.
Alejandro Val 2006/02/16 17:29
Here is a error in env.ksh. Fix the lines (sign = is missing):

11,12c11,12
< then LD_LIBRARY_PATH=$CASROOT/../3rdparty/$OS_NAME/TclTk/lib:$CASROOT/$OS_NAME/lib;
< else LD_LIBRARY_PATH=$CASROOT/../3rdparty/$OS_NAME/TclTk/lib:$CASROOT/$OS_NAME/lib:$LD_LIBRARY_PATH;
---
and libTKDraw.so go away...Now I am working in libtcl.so.0 :-(
Alejandro Val 2006/02/16 21:16
I solve the problem with libtcl.so.0.
I have Fedora Core4 and this distributions does not have the library where opencascade expect. (I assume you have tcl installed). Then make the links:

ln -s /usr/lib/libtk8.4.so /usr/lib/libtk.so.0
ln -s /usr/lib/libtcl8.4.so /usr/lib/libtcl.so.0
Bill Jones 2004/08/09 22:27
Thanks for the advice, but I have a different problem that may be related.

Either way (running installer or `java -jar`) I get the OCC splash screen and the a window with a portion (half width, 1/4 height) filled with what appears to be the license agreement. The trouble is that since this window is not complete, I cannot read nor accept the agreement.

Any help would be appreciated. System is RH 8.0
Etienne LORRIAUX 2004/11/25 14:18
Erkka Westman : I'm using 2.6.9 kernel (gentoo distro) and it works fine. It can be a problem with your java machine or glibc version. I use blackdown for java and glibc-2.3.3.20040420-r2 (i had problems with glibc 2.3.4).

Hunter : "No such file or directory" does not mean that you don't have these libraries on your hard disk, but that your system can't find them. So you have to correctly set up your environment variables (as mentionned in the installation guide)

 
 
Latest news
  • Open CASCADE Technology 6.8.0 is available for download!
  • New features to enhance the development process
  • Open CASCADE Technology 6.7.1 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map