Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
 

Missing surfaces in 6.5.4

Missing surfaces in 6.5.4
fester 2012/12/28 06:29
Linux Ubuntu 12.04.1
FreeCAD 0.13 rev 1766 (GR)
OpenCASCADE 6.5.4


I just compiled and installed 6.5.4 and am using it in FreeCAD 0.13.
When I reach some unknown level of complexity, when using the CUT function, surfaces start going missing.

(I'm only guessing, but it seems like that's the kind of thing to expect if the program had run out of memory.)

(Please run the attached file DEMO.fcstd in FreeCAD.)

Choose Part workbench

Select Cut012
Ctrl Torous002
Make a cut of two shapes

At the point where the shapes intersected, note how the appropriate surfaces are missing, and an inappropriate one is still there.

Is there anything I can do about that?

You have to be logged in to download the attached file
ratnadeep mukkirwar 2013/01/05 16:34
Hi Fester,
I am also facing similar problem. I am trying to use BRepAlgoAPI_Common for getting common between helical tubes and a cylindrical surface but for some reason it is missing surfaces and adding some inapproproate ones.
I am a new user to OCCT. I am wondering if going back to older versions of opencascade can help me. Have you tried it before with any other older versions?? Also did you get any solution?
Thank you.
fester 2013/01/05 17:17
> Have you tried it before with any other older versions??

This has been a problem since 6.5.2. The only older version available for download is 6.5.1, so I don't plan to try it. This was a very good idea though!

> Also did you get any solution?

No. So far you are the only one to reply. Thank you for replying, this proves I'm not the only one with the problem!
kylin 2013/01/17 10:48
I'm now with the similar problem, when using new api BRepAlgoAPI_Cut to cut some cylinder from anotherone, it looses some faces. Meanwhile the old api BRepAlgo_Cut works well. I think it's a common problem. May it be fixed soon.
PG 2013/01/18 09:43

It works in OCC 6.3.X series with BRepAlgoAPI_Cut !!!

It fails in in OCC 6.5.4 Test harness environment on Win7 too using bopargcheck command
fester 2013/01/19 06:39
Do you know where I can get OCC 6.3.X? (It is no longer available on the Open Cascade Website.)
Forum supervisor 2013/01/21 12:24
Dear fester,
You can find it at the next link
http://files.opencascade.com/delivery/download/OpenCASCADE_win32_631.exe.
Just take into account, please that we not support more this old version.
Regards
fester 2013/01/22 07:36
Is there a link available for the Linux version?
Forum supervisor 2013/01/22 11:34
Dear fester,
Only source package is available:
http://files.opencascade.com/delivery/download/OpenCASCADE_src_631.tar.gz
You should build it by your own.
Regards     
Forum supervisor 2013/01/18 14:12
Dear kylin,
Unfortunately it is not possible to reproduce your case because OCCT is not support *.fcstd format.
Simple test with two cylinders was successful. No missed faces.

Draw[]> pcyl cy1 20 100
Draw[]> plane pln -50 0 50 1 0 0
Draw[]> pcyl cy2 pln 15 100
Draw[]> don cy1 cy2
# cy1 cy2
Draw[]> bop cy1 cy2
Draw[]> bopcut Result
Draw[]> don Result
Draw[]> vdisplay RC
Draw[]> vfit
See the result attached.
If it is possible could you attach a script
and arguments of the operation in any format supported by OCCT.
Regards
You have to be logged in to download the attached file
PG 2013/01/22 14:33
     Tried to create cylinder's from the above data (brep attached). trying to perform 'bopargcheck' before using the cut operation gave a message that the shapes are not suitable for boolean in 6.5.4 windows test harness. why ?
You have to be logged in to download the attached file
Forum supervisor 2013/01/22 15:46
Dear PG,
The issue is not reproducible in OCC6.5.4 (vc9 win32) environment.
See below.
Draw[40]> restore cylin.brep cylin
#cylin
Draw[41]> restore cylout.brep cylout
#cylout
Draw[42]> fit
Draw[43]> bopargcheck cylin
# Shape(s) seem(s) to be valid for BOP.

Draw[44]> bopargcheck cylout
# Shape(s) seem(s) to be valid for BOP.

Draw[45]> bopcheck cylout
# This shape seems to be OK.

Draw[46]> bopcheck cylin
# This shape seems to be OK.

Regards
PG 2013/01/22 16:14
     
Thanks.
After restoring the brep's as 'out' and 'in', i did a bopargcheck with with -C (cut) option. Am i doing something wrong ?

# brestore cylin in
# brestore cylout out
# bop out in
# bopargcheck out in -C
faulties, that can not be treated by BOP, are detected

PG 2013/01/22 16:20
     
just a small correction - typo mistake
# brestore cylin.brep in
# brestore cylout.brep out

but, bopcut R returns a valid shape !!!!
Forum supervisor 2013/01/22 16:58
Warning returned by <bopargcheck out in -C>
may be the result of <bopargcheck ..> bug or it may be result of
not synchronized criteria of validity. It is not possible
to identify it right now as it requires more deep investigation.
I suggest you you to register the issue in Mantis Bugtracker which
is available via the Collaborative portal -
http://dev.opencascade.org/index.php?q=home/get_involved.
Regards
 
 
Latest news
  • OCCT Applications
  • Open CASCADE Technology 6.8.0 is available for download!
  • New features to enhance the development process

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map