Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
Open CASCADEShowroomGet it!Developer CornerSupport and ProductsAbout us
Technical overview
Areas of use
Advantages
FAQ
Screenshots
Shape factory
Shape gallery
Demonstrations
What's new
System requirements
Download Center
Public license
Documentation
Getting started
Forums
Open Source community
Training and e-learning
A-la Carte Support
Value-added software
Complementary Components
Customer Corner
Company Profile
Marketing Materials
Contact Us
News
Home / Developer Corner / Forums / Draw and samples / can't run draw test harness and samples anymore

can't run draw test harness and samples anymore

can't run draw test harness and samples anymore
Peter 2012/09/08 19:53
Hello,

two months ago I downloded OCCT 6.5.3 and tried to execute the samples and draw test harness. Everything worked fine. But now, I get this error message when I try to execute programs: the procedure entry point "??task_group_context@tbb@@QAE@XZ" couldn't be located in the dynamic link library "tbb.dll".
I reinstalled OCCT but didn't help. My OS is Windows 7 Professional 64-bit. Is it possible that an Windows Update is the reason for the troubles?
Please let me know how I can solve this problem.
Thank you in advance.

Kind regards

Peter
Forum supervisor 2012/09/10 11:06
Dear Peter,
First you should decide: do you really need TBB?
In OCCT6.5.3 only Standard and BRepMesh units may use TBB services.
If your answer is 'yes', you may check tbb.dll with dependency walker to identify the real reason.
if - 'no', you may rebuild OCCT6.5.3 without TBB. Just comment line "set HAVE_TBB=true" in 'custom.bat' file.
Regards
Roman Lygin 2012/09/10 13:08
Peter,

Probably your environment got contaminated with some software you recently installed, which brings tbb in itself. Now when you try to start OCC another tbb version gets loaded instead of one shipped with OCC. As TBB provides binary compatibility, chances are that an older version has been installed.

To check which tbb is used you might want to inspect the PATH variable and to use Dependency Walker. You will probably need to make sure that OCC's tbb appears in the PATH prior to the other one - using .bat files should help.

Good luck,
Roman
 
 
Latest news
  • New features to enhance the development process
  • Open CASCADE Technology 6.7.1 is available for download!
  • Open CASCADE Technology 6.7.0 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map