Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
 

Build Open Cascade on Centos-6.2 64

Build Open Cascade on Centos-6.2 64
NathanaŽl Geng 2012/07/03 10:53
Hello All,

I'm trying to build OCC, without success up to now...
I think my trouble come from FTGL and Freetype.

Here you can see the command ran for configure:
./configure --enable-production=yes --with-tcl=/usr/lib64 --with-tk=/usr/lib64 --with-freetype=/usr/include/freetype2 --enable-draw=yes --with-ftgl=/usr/include/FTGL

And here some extract of the output:

-> 3rdparty mandatory products
-> ---------------------------------
-> freetype : (--with-freetype=DIR option was not defined)
-> ftgl : no (ftgl was not found)
-> tcltk : yes

In case of need I can post the log file.

If I run the make, the build stop with theses lines:

-> libtool: link: (cd ".libs" && rm -f "libTKOffset.so.0" && ln -s "libTKOffset.so.0.0.0" "libTKOffset.so.0")
-> libtool: link: (cd ".libs" && rm -f "libTKOffset.so" && ln -s "libTKOffset.so.0.0.0" "libTKOffset.so")
-> libtool: link: ( cd ".libs" && rm -f "libTKOffset.la" && ln -s "../libTKOffset.la" "libTKOffset.la" )
-> make[3]: Leaving directory `/opt/OpenCascade-6.5/ros/adm/make/TKOffset'
-> make[3]: Entering directory `/opt/OpenCascade-6.5/ros/adm/make'
-> make[3]: Nothing to be done for `all-am'.
-> make[3]: Leaving directory `/opt/OpenCascade-6.5/ros/adm/make'
-> make[2]: Leaving directory `/opt/OpenCascade-6.5/ros/adm/make'
-> make[2]: Entering directory `/opt/OpenCascade-6.5/ros'
-> make[2]: Leaving directory `/opt/OpenCascade-6.5/ros'
-> make[1]: Leaving directory `/opt/OpenCascade-6.5/ros'

rpm -ql freetype ftgl give me the directory used in the ./configure function.

Could one guide me for solving this?

Thanks in advance for your help!

NathanaŽl.

thomas 2012/07/05 18:45
Hi NathanaŽl

I'm interested to know whether it's possible to compile OpenCascade for RedHat Enterprise 6.2 (I guess CentOS 6.2 is similar ?).

If anyone know if it's possible, please tell me. I cannot try it right now but I will have to do it soon enough.

On topic, did you see the related thread concerning OCC compilation and FTGL issue ?
http://www.opencascade.org/org/forum/thread_23015/?forum=4
NathanaŽl Geng 2012/07/30 23:52
Hello,

Thank you for the reply and sorry for the delay (I just finish my holidays).
I missed this post and plan to use it for changing my set-up.

Here you will find the commands I enter for Centos 6.2 64 :
aclocal
libtoolize --force
autoconf
automake --add-missing
autoreconf
mkdir build
cd build
LDFLAGS="-L/lib64 -L/usr/lib64" \
CFLAGS="-march=native -mavx -m64 -fpermissive" \
CXXFLAGS="-march=native -mavx -m64 -fpermissive" \
../configure \
--prefix=/opt/OpenCascade-6.5 \
--libdir=/usr/lib64 \
--with-java-include=/usr/lib/jvm/java/include \
--with-ftgl=/usr/include \
--with-tcl=/usr/lib64 \
--with-tk=/usr/lib64 \
--with-freetype=/usr/include/freetype2 \
--with-qt \
--with-qt=/usr/lib64/ \
--with-x=yes \
--x-includes=/usr/include/xorg \
--x-libraries=/usr/lib64/xorg \
--enable-production=yes \
--enable-draw=yes \
--enable-debug=no

Up to now without success, it seems that my FTGL installation is wrong... I will work on it and keep you informed!

NathanaŽl.
Raymond 2012/10/20 21:44
      Hello,

I had intended to compile on centos 6 (6.3 actually), it seems you should download, as suggested in OCCT_Build3rdParty_Linux.pdf, Ftgl 2.1.2 and FreeType 2.3.7. The versions on centos are too recent.

Then use the install directory you specified for these libs for the --with-ftgl and --with-freetype switches.

I hope it will help. It worked for me.
Ali 2013/02/26 17:05
     Dear Raymond,

could please tell me how to install OCCT on centos 6.3.
 
 
Latest news
  • New features to enhance the development process
  • Open CASCADE Technology 6.7.1 is available for download!
  • Open CASCADE Technology 6.7.0 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map