Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
 

Installed on XP and fails to run DRAWEXE

Installed on XP and fails to run DRAWEXE
Gavin Millington 2012/03/07 22:16
I've install a standard package using the MSWindows installer. On running the Draw Test Harness, I've getting the follow message from the DOS BAT file:
Command:DRAWEXE.exe
Error:'The system cannot execute the specified program.'

I've tried running the file directly from a DOS window and get the same error.
Running from a Windows Directory window gives:
This application failed to start because the application configuration is incorrect.
The file in question is installed at:
C:\Program Files\OpenCASCADE6.5.2\ros\win32\vc8\bin

Any suggestions?
Gavin.
P.S. I searched the forum and no windows user has posted about this.
Sharjith Naramparambath 2012/03/07 22:41
Download and install the Visual Studio runtime libraries. This should solve the issue.

http://www.microsoft.com/download/en/details.aspx?id=3387
Gavin Millington 2012/03/07 23:45
Thanks Sharjith for the Help but it didn't work. I still get the same errors.
Toutenkamion 2012/03/16 11:47
Thanks Sharjith for the Help but it didn't work. I still get the same errors with Visual 2005, 2008 and 2010.

Toutenkamion.
Forum supervisor 2012/03/16 12:19
Dear Gavin,
You can check the content of draw.bat & env.bat (which is called from draw.bat).
First check the env. variable CASROOT (is it defined correctly?).
Also home directories for 3rdparty products should be correctly defined (see env.bat).
And after check PATH variable (see for details "Open CASCADE Technology Installation\System Environment Variables" from html documentation). Paths to 3rdparty libs and OCCT libs should be defined correctly.
Don't forget that the libraries from the current release are built with VStudio 2005 Professional Edition. If you don't have it installed you should at least install corresponding redistributable package of VC++.
If you plan to use another compiler (possible options VC9 or VC10) you will be forced to rebuild Open CasCade from scratch starting for sure from 3rdparty products (see for details "Compilation of third-party products" from html documentation).
As the last step (if all is correct and a reason is still not clear) you can check DRAWEXE with dependency walker.
Analyze it and find what is defined incorrectly.
Hope it will help.
Regards
 
 
Latest news
  • Open CASCADE Technology 6.8.0 is available for download!
  • New features to enhance the development process
  • Open CASCADE Technology 6.7.1 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map