Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
Open CASCADEShowroomGet it!Developer CornerSupport and ProductsAbout us
Technical overview
Areas of use
Advantages
FAQ
Screenshots
Shape factory
Shape gallery
Demonstrations
What's new
System requirements
Download Center
Public license
Documentation
Getting started
Forums
Open Source community
Training and e-learning
A-la Carte Support
Value-added software
Complementary Components
Customer Corner
Company Profile
Marketing Materials
Contact Us
News
Home / Developer Corner / Forums / Installation and building / Install OpenCascade on RHEL5

Install OpenCascade on RHEL5

Install OpenCascade on RHEL5
Dragos 2009/01/19 11:11
I try to install OpenCascade on RHEL5 (32bit and 64bit) and I am not successful.

First at configure stage I see some warnings:

//////////////////

#./configure $flags --prefix=/opt/OpenCascade6.3.0
.
.
.
.
checking X11/extensions/multibuf.h presence... yes
configure: WARNING: X11/extensions/multibuf.h: present but cannot be compiled
configure: WARNING: X11/extensions/multibuf.h: check for missing prerequisite headers?
configure: WARNING: X11/extensions/multibuf.h: proceeding with the preprocessor's result
configure: WARNING: ## ------------------------------------ ##
configure: WARNING: ## Report this to bug-autoconf@gnu.org. ##
configure: WARNING: ## ------------------------------------ ##
checking for X11/extensions/multibuf.h... yes
.
.
.
.

//////////////////

This is a bug for sure. Then I try to compile the sources and I get:

//////////////////

# make
cd . && /bin/sh /compile/OpenCASCADE6.3.0/ros/make/missing --run aclocal-1.7
cd . && \
/bin/sh /compile/OpenCASCADE6.3.0/ros/make/missing --run automake-1.7 --foreign Makefile
Makefile.am:3: directory should not contain `/'
make: *** [Makefile.in] Error 1

//////////////////

However, if a issue a second make the compilation seems to work but when I do make install I believe a lot of libraries are left in the build location. This is what I have in lib after make install:

//////////////////

#pwd
/opt/OpenCascade6.3.0/lib
# ls -al
total 16780
drwxr-xr-x 2 root root 4096 Jan 18 23:13 .
drwxr-xr-x 8 root root 4096 Jan 18 11:55 ..
lrwxrwxrwx 1 root root 16 Jan 18 23:13 libTKernel -> libTKernel.0.0.0
lrwxrwxrwx 1 root root 16 Jan 18 23:13 libTKernel.0 -> libTKernel.0.0.0
-rwxr-xr-x 1 root root 17120955 Jan 18 23:13 libTKernel.0.0.0
-rwxr-xr-x 1 root root 733 Jan 18 23:13 libTKernel.la

//////////////////

For completeness I am also attaching the contents of a file which sets up the flag and the environment variables.

//////////////////

flags=
flags="$flag --with-gl-include=/usr/include"
flags="$flags --with-gl-library=/usr/lib"
flags="$flags --with-tcl=/usr/lib"
flags="$flags --with-tk=/usr/lib "
flags="$flags --with-xmu-include=/usr/include"
flags="$flags --with-xmu-library=/usr/lib"
flags="$flags --with-java-include=/usr/lib/jvm/java-1.6.0-sun-1.6.0.11/include"
flags="$flags --enable-static=no"
flags="$flags --enable-shared=yes"
flags="$flags --enable-debug=yes"
flags="$flags --enable-production=yes"
flags="$flags --enable-draw=yes"
flags="$flags --enable-wok=yes"
flags="$flags --enable-wrappers=yes"

export flags
export DISTRIBUTIVE_DIR=/compile/OpenCASCADE6.3.0/ros
export CASROOT=${DISTRIBUTIVE_DIR}

//////////////////

Could anyone help me out? Is anybody using OpenCascade on RHEL5? To me it looks like the configuration files are corrupted. I see a lot of compiled libs with an 'U' at the end of the file, e.g.,

//////////////////

# pwd
/opt/compile/OpenCASCADE6.3.0/ros/adm/make/TKBinXCAF/.libs
# ls -al
total 896
drwxr-xr-x 2 root root 4096 Jan 18 23:24 .
drwxrwxrwx 4 root root 4096 Jan 18 00:22 ..
lrwxrwxrwx 1 root root 18 Jan 18 00:22 libTKBinXCAF -> libTKBinXCAF.0.0.0
lrwxrwxrwx 1 root root 18 Jan 18 00:22 libTKBinXCAF.0 -> libTKBinXCAF.0.0.0
-rwxr-xr-x 1 root root 872332 Jan 18 00:22 libTKBinXCAF.0.0.0U
lrwxrwxrwx 1 root root 18 Jan 18 00:22 libTKBinXCAF.la -> ../libTKBinXCAF.la
-rw-r--r-- 1 root root 1510 Jan 18 00:22 libTKBinXCAF.lai

//////////////////

Thank you in advance for your help.

Best regards,
Dragos
Buehler Paul 2009/11/25 09:05
Hi,

I have the same problem. Did you meanwhile find a solution?

Paul
WangYue 2009/11/26 12:41
Try the following step

% aclocal
% libtoolize --force
% autoconf
% automake
% mkdir build
% source flag.sh
% cd build
% ../configure --prefix=/usr/local/pkgs/OpenCASCADE-6.3.0 ${flags}
% make
% make install


flag.sh is defined as following:

TCLHOME="/usr"
flags="--with-gl-include=/usr/include --with-gl-library=/usr/lib"
flags="$flags --with-xmu-include=/usr/include/X11/Xmu/"
flags="$flags --with-xmu-library=/usr/lib/"
flags="$flags --with-tcl=${TCLHOME}/lib"
flags="$flags --with-tk=${TCLHOME}/lib"
flags="$flags --with-java-include=/usr/lib/jvm/java-1.4.2/include/"
#flags="$flags --disable-debug --enable-production"
flags="$flags --enable-production"


Arthur Magill 2009/12/02 11:13
I wrote these instructions on a Fedora machine, but they should work for pretty much any Linux:

http://www.pythonocc.org/wiki/index.php/Installing_OpenCASCADE_on_Linux#Manual_Build
 
 
Latest news
  • New features to enhance the development process
  • Open CASCADE Technology 6.7.1 is available for download!
  • Open CASCADE Technology 6.7.0 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map