Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
Open CASCADEShowroomGet it!Developer CornerSupport and ProductsAbout us
Technical overview
Areas of use
Advantages
FAQ
Screenshots
Shape factory
Shape gallery
Demonstrations
What's new
System requirements
Download Center
Public license
Documentation
Getting started
Forums
Open Source community
Training and e-learning
A-la Carte Support
Value-added software
Complementary Components
Customer Corner
Company Profile
Marketing Materials
Contact Us
News
Home / Developer Corner / Forums / Installation and building / OCC63 - Makefile.am:3: directory should not contain `/'

OCC63 - Makefile.am:3: directory should not contain `/'

OCC63 - Makefile.am:3: directory should not contain `/'
Bob Mitchel 2008/09/15 19:12
Attempting to compile occ63 on Debian Lenny/AMD64.

When I run make I get the following:
$ make
cd . && /bin/sh /opt/OpenCASCADE6.3.0/ros/make/missing --run aclocal-1.7
cd . && \
/bin/sh /opt/OpenCASCADE6.3.0/ros/make/missing --run automake-1.7 --foreign Makefile
Makefile.am:3: directory should not contain `/'
make: *** [Makefile.in] Error 1



Configured with ./configure --enable-production=yes --enable-debug=no --with-gl-library=/usr/lib --with-gl-include=/usr/include --with-java-include=/usr/java/blackdown/j2sdk1.4.2/include/ --with-xmu-library=/usr/lib --with-xmu-include=/usr/include/X11 --with-stlport-libname=stlport --with-stlport-library=/usr/lib --with-stlport-include=/usr/include/stlport --with-tcl=/usr/lib/tcl8.4 --with-tk=/usr/lib/tk8.4 --with-x=/usr/lib/X11 --prefix=/opt/occ63 --with-gnu-ld --enable-wrappers=no --enable-wok=no --enable-draw=no

versions:
GNU Make 3.81
automake (GNU automake) 1.7.9
aclocal (GNU automake) 1.7.9
autoconf (GNU Autoconf) 2.61
gcc (GCC) 4.2.3 20071123 (prerelease) (Debian 4.2.2-4)
Bob Mitchel 2008/09/16 18:26
I re-configured with ./configure --enable-production=no --enable-debug=no --with-gl-library=/usr/lib --with-gl-include=/usr/include --with-java-include=/usr/java/blackdown/j2sdk1.4.2/include/ --with-xmu-library=/usr/lib --with-xmu-include=/usr/include/X11 --with-stlport-libname=stlport --with-stlport-library=/usr/lib --with-stlport-include=/usr/include/stlport --with-tcl=/usr/lib/tcl8.4 --with-tk=/usr/lib/tk8.4 --with-x=/usr/lib/X11 --prefix=/opt/occ63 --with-gnu-ld --enable-wrappers=yes --enable-wok=no --enable-draw=yes

When I ran make, it apparently executed configure again, as I got the typical configure output. It then started compiling, and so far (several minutes in) it is working... ?!
Jane Hu 2008/09/22 19:12
It happend to me too just now.

Jane
Ha Le 2010/01/22 00:04
Hi guys,
I ran to the same problem. Has anyone got a solution for this?
Thanks
 
 
Latest news
  • Open CASCADE Technology 6.7.0 is available for download!
  • Open CASCADE Technology 6.6.0 is available for download!
  • Open CASCADE Technology 6.5.5 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map