Open CASCADE, the 3D modelling kernel
3D modeling & numerical simulation

Search the Forums
See All Topics
Open CASCADEShowroomGet it!Developer CornerSupport and ProductsAbout us
Technical overview
Areas of use
Advantages
FAQ
Screenshots
Shape factory
Shape gallery
Demonstrations
What's new
System requirements
Download Center
Public license
Documentation
Getting started
Forums
Open Source community
Training and e-learning
A-la Carte Support
Value-added software
Complementary Components
Customer Corner
Company Profile
Marketing Materials
Contact Us
News
Home / Developer Corner / Forums / Installation and building / RE-installation does not show 'Choose Directory' option

RE-installation does not show 'Choose Directory' option

RE-installation does not show 'Choose Directory' option
Nishant Mehta 2008/02/05 10:36
After a couple of install uninstall cycles, the installer stopped giving me the option to choose the installer directory. It picks up the directory which contains setupWindows.exe is the installation location. Any ideas would be appreciated.

Just to note I am doing this in Vista which is probably not supported but because this worked fine once, I am hoping a little tinkering with the registry/env could get me going again if someone could point me to where I should look.

I am using VS2008 for building *BUT* that at the moment is irrelevant I guess(builds fine with the usual tweaks BTW).
J 2008/02/07 10:51
I had the same thing. Did you fulle uninstall? The problem first appeared when I installed a second copy on me computer (this goes beyond logic). Make sure you completly deinstall, remvoing old folders etc. This worked for me, I don't think it has any registry or windows entries but try them too. Then install again and it will show.
Nishant Mehta 2008/02/07 13:55
Thanks J.

Yes I did a full install. I tried cleaning up everything I could find. Did not work. I didn't find any registry entries, but I tried deleting the environment variables. A lot of install uninstall cycles but just didn't work.

What did work though is copying the setupWindows.exe and the jar file to the directory i wanted to install it to and then running it. Installed fine but very dirty way of doing it I think. Tried uninstalling and then installing again but same prob. Here's where I gave up and used the dirty way.

My wild guess is, for un-installation the path should be pre-selected and unchangeable, which means the installer probably gets confused whether to start in installation or un-installation mode. Must be reading some value(s) somewhere to decide. But its just a wild guess.
Jeff Moody 2009/03/11 23:16
Nishant,
I had the same issue. Thanks for the workaround.

In my case, what I originally wanted to do was reinstall a subset of the components, so I did the following:
- ran the installation again
- only checked the checkboxes for the mfc sample components
- finished installation
- I couldn't find any of the mfc sample components, so I figured I'd start over.
- I ran the uninstall, which now only shows options to remove the mfc sample components, so I selected these for removal and deleted the rest of the files manually.

Hopefully someone from the OpenCASCADE development team sees this so they can fix it for future releases.
Jeff Moody 2009/03/12 00:18
Strange- after using your workaround to install to the original location, very few files were actually installed to this folder.
So I immediately uninstalled, then deleted the folder.
I then ran the installer again, and this time it asked to accept the license agreement and then asked for the destination.

It seems to have installed fine.
 
 
Latest news
  • Open CASCADE Technology 6.7.0 is available for download!
  • Open CASCADE Technology 6.6.0 is available for download!
  • Open CASCADE Technology 6.5.5 is available for download!

  • © OPEN CASCADE 2000 - 2014  |  Search  |  Contacts   |  Site map